Web Toolbar by Wibiya

Author Topic: Firestorm e-trigger issue?  (Read 3696 times)

0 Members and 1 Guest are viewing this topic.

Offline paintman161

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +1/-0
  • Gender: Male
Firestorm e-trigger issue?
« on: March 17, 2011, 10:59:46 AM »
So i have a Firestorm e-trigger and it is not working! I was shooting my marker and chronoing it, when it just stopped firing, i took out the mag and checked it still nothing. I removed the air still nothing, the trigger eas not activating. SO i took off the grip and checked it out, seems like everything is okay. I checked the battery to make sure it is charged, i put my Ohmeter on it and came up with 32 mAh, which should be more than enough, since a 9v runs at 25 mAh. It does not matter which firing mode i put it on, it will not fire at all. I do hear the micro switch clicking, but that is the only thing moving. Not sure what happened but one second it was working great and the next nothing! I have only shot like 60 paintballs through the marker using the e-grip.

Any one have any ideas here, is the board fried or something?

Offline pirahna590

  • Sr. Member
  • ****
  • Posts: 301
  • Karma: +3/-1
  • Gender: Male
Re: Firestorm e-trigger issue?
« Reply #1 on: March 17, 2011, 01:02:55 PM »
did ur board get wet?? I dont have a firestorm egrip, but havent seen any egrips where they were completely waterproof so if u played in the rain one day its quite possible some water got in there an friend the board. Im not positive this is whats wrong, just an idea.

Offline paintman161

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +1/-0
  • Gender: Male
Re: Firestorm e-trigger issue?
« Reply #2 on: March 17, 2011, 02:29:16 PM »
Nope never even been outside. I was shooting it inside to chrono the gun and it just stopped working. the solenoid does not go clicky, just the micro switch.

Offline paintman161

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +1/-0
  • Gender: Male
Re: Firestorm e-trigger issue?
« Reply #3 on: March 17, 2011, 04:12:11 PM »
Its weird, but i just tried it again and now it works! Just a little confused as to way now it works? Maybe the battery was too hot??? I am lost on this one.

Offline cesarumana

  • Jr. Member
  • **
  • Posts: 81
  • Karma: +2/-0
  • I love RAP4
Re: Firestorm e-trigger issue?
« Reply #4 on: March 17, 2011, 05:34:24 PM »
The only time Ive had my e-trigger fail is if the selector switch for the rate of fire isnt perfectly set on the rate you want. If its even off a little bit it wont fire.

Offline pirahna590

  • Sr. Member
  • ****
  • Posts: 301
  • Karma: +3/-1
  • Gender: Male
Re: Firestorm e-trigger issue?
« Reply #5 on: March 17, 2011, 06:16:25 PM »
it COULD be the battery couldnt keep up with the demands of the e-trigger .... wore itself out then slowly recharged? Could also be as Cesa suggested too, maybe you didnt have the switch exactly in the right position? Try a duracell, they tend to hold up better with demanding electronics like cameras an e-triggers. Let us know how you make out, it what were all here for :D

Offline azntactical

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: +6/-0
  • Gender: Male
  • The T68 is my cup of tea.
Re: Firestorm e-trigger issue?
« Reply #6 on: March 18, 2011, 02:06:02 AM »
but the rechargables are 9.6v...the regular batterys are only 9v. according to rap4, if you want the best out of these e-trigs, 9.6v is best for its operation.
if you dont have the selector switch in the right position, it will not fire or make any type of noise. highly doubt your battery was low, because my brother had one and played a good 4-6 hours worth and was still operational w/o a recharge.

Offline paintman161

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +1/-0
  • Gender: Male
Re: Firestorm e-trigger issue?
« Reply #7 on: March 18, 2011, 06:15:30 AM »
The only time Ive had my e-trigger fail is if the selector switch for the rate of fire isnt perfectly set on the rate you want. If its even off a little bit it wont fire.

Yea i looked into that already, It is pretty picky but i made sure it was in the correct position, besides it was not working in any of the modes.

Offline paintman161

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +1/-0
  • Gender: Male
Re: Firestorm e-trigger issue?
« Reply #8 on: March 18, 2011, 06:16:47 AM »
it COULD be the battery couldnt keep up with the demands of the e-trigger .... wore itself out then slowly recharged? Could also be as Cesa suggested too, maybe you didnt have the switch exactly in the right position? Try a duracell, they tend to hold up better with demanding electronics like cameras an e-triggers. Let us know how you make out, it what were all here for :D

i did try another Duracell 9v and still did not work.

Offline paintman161

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +1/-0
  • Gender: Male
Re: Firestorm e-trigger issue?
« Reply #9 on: March 18, 2011, 06:18:42 AM »
Just tried it again and it seems to be working all normal now. Maybe it was a loose connection at the battery somehow. IDK

Offline azntactical

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: +6/-0
  • Gender: Male
  • The T68 is my cup of tea.
Re: Firestorm e-trigger issue?
« Reply #10 on: March 19, 2011, 10:55:18 AM »
could of been that. maybe perhaps you thought you secured the battery into the connector but only one was connected and the other didnt.

Offline paintman161

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +1/-0
  • Gender: Male
Re: Firestorm e-trigger issue?
« Reply #11 on: March 20, 2011, 07:57:45 AM »
It was the first thing i checked :) not a newb here:)

Offline BMW Sniper

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
  • Gender: Male
  • RAP4 beat Milsig anyday of the week!
Re: Firestorm e-trigger issue?
« Reply #12 on: December 01, 2012, 07:48:02 PM »
Hey anyone have any ideas on how to disable the 3 minute auto shut off. Playing milsim means that you might not use the trigger for 3 mins and when you do need to use it you are often left for dead. Having to keep switching modes every few minutes to keep the trigger live is a real pain.

Offline azntactical

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: +6/-0
  • Gender: Male
  • The T68 is my cup of tea.
Re: Firestorm e-trigger issue?
« Reply #13 on: December 01, 2012, 07:56:10 PM »
Hey anyone have any ideas on how to disable the 3 minute auto shut off. Playing milsim means that you might not use the trigger for 3 mins and when you do need to use it you are often left for dead. Having to keep switching modes every few minutes to keep the trigger live is a real pain.

do you have the newer versions with those safety shots? i never had a problem with mine, when i had it. but, i had the older versions that had the true 3 round and full auto w/o safety shots.

Offline BMW Sniper

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
  • Gender: Male
  • RAP4 beat Milsig anyday of the week!
Re: Firestorm e-trigger issue?
« Reply #14 on: December 01, 2012, 08:10:43 PM »
Yup mine fires 3 single shots prior to going semi or full auto